ROVL MKII IMU Status issues

Hi All,

Having a bit of an issue getting my MKII system calibrated. Recently updated to the 2023-03-07 firmware.

I have been working through the procedures on this page: IMU Calibration General Procedures

After following everything in order I get a “2332” status and then once more rotating it around for the mag I get either “3033” or “3303”. Sometimes it switches between the two statuses. I’ve never gotten a “3333”.

Is the system calibrated if that first digit is a “3”?

1 Like

Hi Kevin once you have registered a calibration number, it does no matter if it goes back to zero. I will check with the team on Monday, but if you gotten at least a 2 value - I believe you should be ok.

I will let you know Monday - Cheers !

Ok I realize that accumulative, you registered the value “3” on all digit positions- so you should be ok.

But I will triple check on Monday!

Great thanks! Thats kinda what I thought when the overall system status went to 3.


The behavior you described is often what happens when you try to calibrate the IMU in a badly disturbed magnetic environment, such as in a building framed in steel girders, over a concrete floor with rebar and cast iron piping, on a desk with a steel frame, on a steel-hulled boat, next to a boat’s diesel engine, if steel or iron clamps are used to mount the receiver, etc. What happens is the equivalent of cognitive dissonance. When the IMU pays attention to the magnetometer, it notices the gyro inputs don’t match the expected motions, and vice versa. Same with the accelerometers and gyros. This cause the calibration status of one of the subsystems to drop. So, look at that first.

Another less likely possibility is the calibration parameters saved in the system were originally done in a much different magnetic environment and are now very far off from the current environment. If the calibration is too far off, it will take quite a while to get back to a good setting for the current environment, and if you don’t reset the calibration parameters this will happen each time you power up. You should get it to achieve 3333 status, and then save the calibration parameters immediately (the ‘Y’ command) to make the next and subsequent startups much easier.

IMU calibration generally adds only a small increase in accuracy, so sometimes you use the system for no matter what the calibration status says. But, if you want best accuracy, you should get it to achieve 3333 status. Beware, sometimes the IMU really does need the calibration dance to initially find north after power up.

The release of software you are using has a new feature, the ability to put the IMU into NDOF or COMPASS modes, as described in the user manual here. This section was updated from the one you looked at. COMPASS mode is essentially the same as what the BlueROV does with its sensors. NDOF adds gyros to the fusion and is more linear and less susceptible to magnetic transients. Your system should have defaulted to NDOF mode when you installed the new software (send ‘?’ to have it list its current settings). Use command ‘T NDOF’ to get it back to NDOF mode if it is in COMPASS mode. Use command ‘T NDOF’ if you want to try COMPASS mode.

If you’re still having problems Dennys can set up a Zoom call when you are trying to calibrate and maybe we can speedily resolve this.

Specifically, if the calibration status reaches ‘3333’, you are likely good if it drops below ‘3333’ for a few minutes.

Hi Don, thanks for the explanation and the path forward to getting a good cal.

My RAM mount clamp is a bit chunky with some sort of metal, so that may be causing the mismatch. I do the dance with everything attached, but I may try it next with the RX out of its pole mount and clamp.

With all that being said, I did have the system working pretty well even in the challenging acoustic environment of the harbor (the weather and visibility are pretty poor right now.)

Looking forward to getting out into some deep water, where this system will excel.

Got my unit fixed! I switched it to COMPASS mode (tried to calibrate) and then switched it back to NDOF mode, redid the calibration and then it went to 3333. I hit “Y” to save and I think I’m all good now.

Just a note, its hard to tell what mode I am in because when I query the current settings it says “IMU mode is NDOF FMC ON” in both instances and there isn’t an indication of when you are in COMPASS mode. Maybe add a radio button like the channel selector?

Had my unit out yesterday and here are my observations:

  1. The ROV compass is dead on.
  2. The ROVL is accurate with position when the IMU maintains its calibration.

Unfortunately, my IMU was losing calibration fairly quickly. It was returning to a 0300 status within about 2 minutes of use. I can pop the pole out of its mount fairly quickly and get it recalibrated, but then within another 1-2 minutes it was out again and my vehicle was showing me tracking position in a completely opposite direction.

I was able to get a 3333 reading repeatedly on the water and saved the calibration, but still kept losing it after a few minutes. Makes for a bit of a frustrating operations day, but at least I’m doing this for fun and not on the clock.

What is the expectation for how long an IMU calibration should hold?

BTW, here’s a log if that helps: Tracker-log 2023-07-02 11-38.csv - Google Drive

Hi Kevin,

I want to triple check that you are working with a Mk II unit (not Mk III.)

IN any case let’s have your Receiver be returned so can work on an upgrade. I will send you a returned shipping label via email.

Thanks, I’ll get this boxed back up so you can take a look.