Sonar view dont identify s500 over wifi

When the S500 is connected to my drone router, it is visible to my ground station when the ground station is connected to the same Router via Wired LAN, but if the ground station is connected to the Router via WiFi then the S500 is no longer visible. Is there a known reason why?

whereas I used ping viewer and manually entered the ip and port and it worked.
I suspect sonar view don’t identify sonar over wifi and does only via wired LAN.
Kindly guide how we can correct it?

If I understand correctly, you have a router in your drone, and this router also has wifi. If so, and you can connect with a wired ethernet connection to the router, then there is no reason why you shouldn’t be able to connect via wifi. Unless there is something strange about the router.

Are you using SonarView to connect? If not, what? Can you ping the S500 over wifi?

I cannot wire connect ground station with remote drone router carying s500.
s500 is only getting detected if its connected to ethernet.GRound station over wifi cant find s500, even though I can ping it from ground station.
But as ping viewer gives option to manually enter ip and ports, I am able to connet via it.
Using sonarview, as it cannot discover the device over wifi and it also dont provide provision to enter ip manually to connect.
PFA Detailed drawing


Hmmm. One difference between the discovery protocol (used by SonarView to find connected devices) and pinging, or connecting directly to an address:port is that discovery uses a udp broadcast. I wonder if the router on the vehicle is perhaps disallowing broadcast requests coming from wifi, and that somehow with your wifi bridge on the shore station, the broadcasts are getting through.

I have confirmation that “wifi will simply drop UDP broadcast requests by default and there is usually an option on the router/AP to enable it.” So possibly you can enable wifi broadcast on your remote device router.

In the meantime, thanks for the full description you sent in the sketch. We will consider some solutions to this issue including probably the manual “connect to device with ip_addr:port” option.

Thanks. That was the issue. I created a router firewall rule allowing all devices to access UDP broadcasts on port 51200 and a windows firewall rule to allow traffic on UDP-51200 for all applications. That solved the problem.

For the router side:

Great. Thanks for the confirmation.