SonarView Device Discovery settings for Ping1 BlueROV2

Hi Larry
I haven’t been able get SonarView to detect Ping1 on my BlueROV and wonder if you could clarify what I need to enter in the settings. The Ping1 works fine with PingViewer and shows the IP/Port

So in SonarView I set the vehicle IP to and enable ‘detect serial devices’ as per the manual.

I’m not sure what to set for the Mavlink port, have tried 9090 and 9094 as well as leaving it empty. There is a setting in the BlueOS companion software to enable Mavlink forwarding although this is unchecked by default. When checked it does highlight a setting ‘hostname:14445’ but not sure this is relevant for Ping1

I’m also not sure what to put for the SonarLink IP address in the SonarLink and Discovery options other than enabling the serial devices toggle. Have tried various options using the vehicle and surface computer IPs and Ping1 ports as well as leaving it blank but hasn’t helped.

Any advice much appreciated as like to try SonarView with this device.


  • Bill

I’m not set up to test at this moment, but I think the mavlink port should be the default value in the app which is 6040.

1 Like

Hi Larry - I changed the Mavlink port to 6040 but still not discovering the PING1 device. I tried various SonarLink IP options as well including the vehicle IP, the default and leaving it blank but not sure its relevant.

I don’t have a Ping1 handy, but the Ping360 interface is the same and seems to be working fine for me here. Reviewing settings:

  • SonarView version 1.7.0
  • Vehicle Settings:, port 6040.
  • SonarLink and Discovery Options: localhost
  • BlueOS Version: 1.1.0-beta.18

Enable Serial devices is not needed, this is only for serial devices on the local computer.

1 Like

Found a Ping1. There are a few issues:

  • We have seen cases on both the Ping 360 and the Ping1 connected through BlueOS where these devices do not appear in the SonarView device discovery. In all instances so far, restarting BlueOS has cleared this up.
  • Once Ping1 does appear in the Device Discovery window, there is a bug SV 1.7.0 that will prevent you from connecting to a Ping1 that is connected via BlueOS. This is fixed now for the next release (expected in a couple weeks).
  • SonarView 1.7.0 is not capable of running multiple windows, so you wouldn’t be able to use SV for both the Omniscan and the Ping1 simultaneously. There is a work around, but due to the issues above, I won’t go further on that one! Working on a fix for this.

Sorry for that. Thanks for the feedback - it’s very helpful! Of course you should still be able to use Ping with PingViewer for now.

1 Like

Many Thanks Larry

Had tried a few times after powering down/restarting BluOS but will keep an eye out for the new SV version :+1:

Unfortunately haven’t been able to use the Omniscan yet as the ethernet switch purchased separately arrived faulty but a replacement has been shipped - very much looking forward to getting that finally running!

Am a bit nervous about its somewhat exposed profile when mounted on the front of the BlueROV. The Cerulean bracket does have a little flexibility but appreciate any advice about minimizing the potential effects of inevitable bumps and scrapes both underwater and on the surface (I have the 100m depth rated version).


  • Bill

Whoops - I missed one of your responses above. Many Thanks and will try these additional settings options when I get a chance and let you know how I go.

  • Bill

I think it would take quite a smack to damage the Omniscan. Let us know if you manage to do it! :slight_smile:

1 Like

Well that’s reassuring :rofl: Thanks Larry!